Select Page

Bufferbloat is a cause of high latency and jitter caused by excess buffering of packets.

Bufferbloat can also cause packet delay variation (also known as jitter). It can reduce the overall network throughput.

When a router or switch is configured to use excessively large buffers, even very high-speed networks can become practically unusable for many interactive applications like voice over IP (VoIP), video and/or audio streaming, online gaming, and even ordinary web browsing.

Bufferbloat occurs when a network link becomes congested, causing packets to become queued for long periods in these oversized buffers. In a first-in first-out queuing system, overly large buffers result in longer queues and higher latency, and do not improve network throughput. It can also be induced by specific slow-speed connections hindering the on time delivery of other packets.

For those using Mikrotik there are some simple solutions – and when CAKE (if ever) finally reaches the TIK community – things will be even better.

First and foremost – lets make sure we have fasttrack is disabled.

Navigate to IP > Firewall then go to Filter Rules

Terminal Entries

In winbox, navigate to “New Terminal”. After the Terminal window opens type in

/queue type

press enter then type in….

add kind=sfq name=sfq-default sfq-perturb=10

then press enter again.

Now type in

/queue simple

press enter then type in….

add max-limit=100M/100M name=sfq-default queue=sfq-default/sfq-default target=192.168.88.0/24 (or whatever subnet you require here)

then press enter.

Calibrating your Max Download and Max Upload Speeds

  1. Make sure nothing is using the network and perform a speedtest from http://www.dslreports.com/speedtest
  2. Take note of your results and calculate 80% to 90% of your bandwidth as the result. (SQM will not work if this percentage is not lower than your top speed!!!)
  3. Navigate to Queues and double-click sfq-default (which was created in terminal)
  4. For your limits enter in 80-90% of your full bandwidth otherwise you will lag! The router needs some extra bandwidth to work with!
  5. Upload is on the left side. Download is on the right side.
  6. Then press Apply and OK.

WordPress Appliance - Powered by TurnKey Linux